क्लासिकप्रेस कम्युनिटी वोट्स टू री-फोर्क वर्डप्रेस – डब्ल्यूपी टैवर्न

क्लासिकप्रेस कम्युनिटी वोट्स टू री-फोर्क वर्डप्रेस – डब्ल्यूपी टैवर्न

दिसंबर 2022 में, क्लासिकप्रेस समुदाय ने इस बात पर मतदान किया कि क्या वर्डप्रेस को फिर से फोर्क करना है या परियोजना के साथ-साथ जारी रखना है। जैसा कि वर्डप्रेस का विकास जारी है, क्लासिकप्रेस PHP 8+ संगतता की खोज में पिछड़ गया। फोर्क वर्डप्रेस 4.9 पर आधारित है और पांच साल पुराने कोडबेस के साथ कौन से प्लगइन्स काम करेंगे, इसमें उपयोगकर्ता तेजी से सीमित हैं।

क्लासिकप्रेस कोर योगदानकर्ताओं तक सीमित एक चर्चा में, परियोजना के निदेशकों में से एक, विक्टर नागोर्नी ने वोट के परिणामों की घोषणा की: “फिर से फोर्क करने के विकल्प में 20 वोट हैं जबकि जारी रखने के लिए 18 हैं।” नागोर्नी ने पिछली चर्चाओं को सारांशित किया और एक दृष्टिकोण सुझाया जो परियोजना के सीमित योगदानकर्ताओं के लिए अधिक यथार्थवादी होगा:

गुटेनबर्ग के बिना क्लासिकप्रेस वर्डप्रेस नहीं हो सकता है, लेकिन यह इस समय एक छोटी सी कोर टीम के साथ स्वयं का सीएमएस भी नहीं हो सकता है। WP से दूर जाने के लिए WP से बैकपोर्टिंग कोड के बिना प्रगति करने के लिए पर्याप्त डेवलपर्स नहीं हैं।

मतदान में लगभग समान विभाजन से पता चलता है कि सबसे अच्छा विकल्प एक संकर हो सकता है, एक समझौता समाधान खोजें जो दोनों पक्षों को संतुष्ट करेगा।

एक छोटी कोर टीम के साथ, हमें अधिक कुशल होने के तरीके खोजने होंगे, कम से अधिक काम करने के लिए। ऐसा करने का एकमात्र तरीका WP योगदानकर्ताओं द्वारा किए गए सभी कार्यों का लाभ उठाना है। जैसे-जैसे कोर टीम बढ़ती है, हम हमेशा WP से अलग होने की संभावना तलाश सकते हैं, लेकिन इस समय यह संभव नहीं है।

पिछली चर्चा में कुछ प्रतिभागियों ने री-फोर्किंग को अपरिहार्य को स्थगित करने के रूप में देखा, अगले री-फोर्क तक सड़क को नीचे गिरा सकते हैं, लेकिन यह एकमात्र विकल्प है यदि उपयोगकर्ता बाकी वर्डप्रेस पारिस्थितिकी तंत्र के साथ संगतता बनाए रखना चाहते हैं।

क्लासिकप्रेस कोर कमिटर अल्वारो फ्रांज ने कहा, “यदि आप हाल के धागे पढ़ते हैं, तो आप पाते हैं कि समुदाय वर्डप्रेस के साथ प्लगइन संगतता की अपेक्षा करता है … फिर से फोर्क विकल्प का एक और कारण है।”

फ्रांज, जो वर्डप्रेस 6.0 पर आधारित WP-CMS फोर्क के लेखक भी हैं, ने पहले कहा था कि वह वर्डप्रेस 4.9 पर आधारित वर्तमान संस्करण को जारी रखने में मदद करने के इच्छुक नहीं होंगे।

“यह [ClassicPress] एक प्रतियोगिता होने की आवश्यकता नहीं है (और वैसे भी यह कभी भी वर्डप्रेस के साथ प्रतिस्पर्धा नहीं कर सकता है), लेकिन यह उन लोगों के लिए एक दुबला संस्करण हो सकता है, जो पहले से ही प्लगइन्स के माध्यम से गुटेनबर्ग को अक्षम कर रहे हैं, उन डेवलपर्स के लिए जो अपने विकास के तरीके के लिए एक अलग दृष्टिकोण चाहते हैं। परियोजनाओं (‘क्लासिक’ अनुभव के करीब, लेकिन अभी तक … आधुनिक!), “फ्रांज ने कहा।

“आखिरकार, वर्डप्रेस की एक नई प्रति चलाने के लिए यह समझ में नहीं आएगा और फिर एक प्लगइन स्थापित करें जो इसके आधे हिस्से को ‘अक्षम’ कर दे। क्या बात है? ऐसा संस्करण क्यों नहीं है जो उस विशिष्ट उपयोग के मामले को कवर करता हो?”

नागोर्नी के प्रस्तावित हाइब्रिड दृष्टिकोण के हिस्से के रूप में, उन्होंने सुझाव दिया कि परियोजना v1.x में क्लासिकप्रेस में पेश किए गए कुछ परिवर्तनों को बरकरार रखेगी, जैसे कि गोपनीयता-उन्मुख परिवर्तन (अज्ञात डेटा सीपी एपीआई को भेजता है), समाचार विजेट, और सुनिश्चित करें कि सभी एपीआई समापन बिंदु क्लासिकप्रेस एपीआई का उपयोग v1.x के रूप में करते हैं।

कांटे के साथ कैसे आगे बढ़ना है, इस पर चर्चा जारी है। क्लासिकप्रेस योगदानकर्ता वर्डप्रेस 6.0 पर आधारित फ्रांज के डब्ल्यूपी-सीएमएस फोर्क का उपयोग करने की ओर झुक रहे हैं, लेकिन अभी तक विवरण को अंतिम रूप नहीं दिया है।

क्लासिकप्रेस कम्युनिटी वोट्स टू री-फोर्क वर्डप्रेस – डब्ल्यूपी टैवर्न क्लासिकप्रेस कम्युनिटी वोट्स टू री-फोर्क वर्डप्रेस – डब्ल्यूपी टैवर्न

प्रातिक्रिया दे

आपका ईमेल पता प्रकाशित नहीं किया जाएगा. आवश्यक फ़ील्ड चिह्नित हैं *